Pesquisar este blog

quarta-feira, 29 de julho de 2009

ABRIR, SALVAR E EDITAR EM DOCX NO UBUNTU 9.04 OPENOFFICE 3.x


Esta semana tive que botar a cabeça para pensar a respeito de um desafio um arquivo de um trabalho que estou realizando tinha que ser aberto editado e salvo em DOCX e devolvido ao destinatario neste formato pavoroso da microsoft, no ubuntu sem as alterações que vou descrever adiante isso é impossível tendo em vista que o openoffice 3.0 apenas abre o documento e mal pois boa parte da formatação nesta versão é defeituosa, se você já instalou o openoffice 3.1 já vai conseguir abrir os documentos de forma decente, porém editar e salvar em docx jamais, ai estava meu dilema, vou lembrando que so consegui excelentes resultados com ubuntu 32 bits pois em 64 bits a coisa desanda talvez pelo grau de desenvolvimento do arquivo odf-converter-integrator que para 32 bits encontra-se na versão 0.2.3 e para 64 bits na versão 0.1.4.b ou seja ainda um beta, mais no ubuntu 9.04 32 com o openoffice 3.X este arquivo depois de instalado transforma docx praticamente em formato nativo, não recomendo ainda a instalação em 64 pois carece ainda de muito desenvolvimento,por isso vou me concentrar na versão i 386 O primeiro passo para a instalação é o download do arquivo no seguinte link http://katana.oooninja.com/w/odf-converter-integrator/download nesta pagina você vai encontrar todas as versões possiveis do arquivo baixe a versão correspondente a seu sistema, a instalação é bastante simples no ubuntu acesse a pasta e clique no arquivo após baixado e o instalador de pacotes fará o resto. Após a instalação reinicie o sistema, e na versão 32 bits ou i386 como desejar chamar é garantido o poder de abrir editar e salvar arquivos em docx como se fosse nativo, não consegui o mesmo resultado em amd_64 com muitos erros de entrada e saída que impossibilitam muitas vezes ate a abertura do arquivo quanto mais sua edição.

Um comentário:

Andres disse...

tinha o aaaabroffice 3.1.1 instalado, instalei esse .deb e ele rebaixou para OpenOffice 2.4 . Resultado, desinstalei e voltei para o BrOffice 3.1.1